Home Help Center

Cannot get slicePHP command to work?

DPMDPM Member Lynn FortinOrganization: Easy Company GamingProject: Mumbles with Ice
I've installed ice, I had to do the compile myself as I'm running PHP 5.3.6 on a linux centOS 5 server. When I run mumbles, it shows ice is loaded and communicating, no errors. I also ran the following and it gave a positive result for ice working:
netstat -apn | grep 6502

I need the slice to work so I can add web admin tools for mumbles which was the whole purpose of the install but nothing I have tried has worked. I am mainly getting sh: slice2php: command not found. I have tried a variety of ways of entering the command and executing it from different directories with no results so I am now totally lost and would appreciate any help that can be provided. Here's a few examples:

[root /]# slice2php /var/lib/mumble-server/Murmur.ice
sh: slice2php: command not found

[root /]# /opt/Ice-3.4.2/bin/slice2php Murmur.ice
/opt/Ice-3.4.2/bin/slice2php: error: cannot open `/Murmur.ice' for reading
[root /var/lib/mumble-server]# /opt/Ice-3.4.2/bin/slice2php Murmur.ice
/var/lib/mumble-server/Murmur.ice:9: error: Can't open include file "Ice/SliceChecksumDict.ice"
#include <Ice/SliceChecksumDict.ice>
1 error in preprocessor.

[root /]# slice2PHP -I/opt/Ice-3.4.2/slice /var/lib/mumble-server/Murmur.ice
sh: slice2PHP: command not found

**********************************
For the install I did the following:

I created a /etc/ld.so.conf.d/IcePHP.conf file and added:
/opt/Ice-3.4.2/lib
/opt/Ice-3.4.2/php

I added the IcePHP.so to my whm extensions list (php.ini).

I added the following to the bottom of my php.ini file:
ice.slice = -I/opt/Ice-3.4.2/slice /var/lib/mumble-server/Murmur.ice

I ran the following tests:

I ran php -m and it lists "ice" under PHP Modules.

I ran php -i and see this for ice:
ice

Ice support => enabled
Ice version => 3.4.2

Directive => Local Value => Master Value
ice.config => no value => no value
ice.hide_profiles => 1 => 1
ice.options => no value => no value
ice.profiles => no value => no value

I ran ldconfig -v as suggested in one of the other forum posts with this result:
[root /etc]# ldconfig -v | less
/opt/Ice-3.4.2/lib:
libIce.so.34 -> libIce.so.3.4.2
libGlacier2.so.34 -> libGlacier2.so.3.4.2
libIceSSL.so.34 -> libIceSSL.so.3.4.2
libIceGrid.so.34 -> libIceGrid.so.3.4.2
libIceGridFreezeDB.so.34 -> libIceGridFreezeDB.so.3.4.2
libFreeze.so.34 -> libFreeze.so.3.4.2
libIceDB.so.34 -> libIceDB.so.3.4.2
libIceXML.so.34 -> libIceXML.so.3.4.2
libIceBox.so.34 -> libIceBox.so.3.4.2
libIceStormFreezeDB.so.34 -> libIceStormFreezeDB.so.3.4.2
libIcePatch2.so.34 -> libIcePatch2.so.3.4.2
libIceStormService.so.34 -> libIceStormService.so.3.4.2
libSlice.so.34 -> libSlice.so.3.4.2
libIceUtil.so.34 -> libIceUtil.so.3.4.2
libIceStorm.so.34 -> libIceStorm.so.3.4.2
/opt/Ice-3.4.2/php:
/lib:
libdevmapper-event.so.1.02 -> libdevmapper-event.so.1.02
libdb-4.2.so -> libdb-4.2.so
libdevmapper-event-lvm2.so.2.02 -> libdevmapper-event-

lvm2.so.2.02
libpam.so.0 -> libpam.so.0.81.5
libauparse.so.0 -> libauparse.so.0.0.0
libsepol.so.1 -> libsepol.so.1
libnss_nisplus.so.2 -> libnss_nisplus-2.5.so
libpam_misc.so.0 -> libpam_misc.so.0.81.2
ld-linux.so.2 -> ld-2.5.so
libdb-4.1.so -> libdb-4.1.so
libglib-2.0.so.0 -> libglib-2.0.so.0.1200.3
libssl.so.6 -> libssl.so.4
libdb_cxx-4.2.so -> libdb_cxx-4.2.so
libpcre.so.0 -> libpcre.so.0.0.1
libdbus-1.so.3 -> libdbus-1.so.3.4.0
libdmraid-events-isw.so.1.0.0.rc13-17 -> libdmraid-events-

isw.so.1.0.0.rc13-17
libgmodule-2.0.so.0 -> libgmodule-2.0.so.0.1200.3
libcrypt.so.1 -> libcrypt-2.5.so
libnss_wins.so.2 -> libnss_wins.so.2
libgcc_s.so.1 -> libgcc_s-4.1.2-20080825.so.1
libvolume_id.so.0 -> libvolume_id.so.0.66.0
libblkid.so.1 -> libblkid.so.1.0
libuuid.so.1 -> libuuid.so.1.2
liblvm2cmd.so.2.02 -> liblvm2cmd.so.2.02
libpamc.so.0 -> libpamc.so.0.81.0
libcrypto.so.6 -> libcrypto.so.4
libtermcap.so.2 -> libtermcap.so.2.0.8
libcom_err.so.2 -> libcom_err.so.2.1
libext2fs.so.2 -> libext2fs.so.2.4
libc.so.6 -> libc-2.5.so
libgobject-2.0.so.0 -> libgobject-2.0.so.0.1200.3
libaudit.so.0 -> libaudit.so.0.0.0
librt.so.1 -> librt-2.5.so
libsemanage.so.1 -> libsemanage.so.1
libpthread.so.0 -> libpthread-2.5.so
libBrokenLocale.so.1 -> libBrokenLocale-2.5.so
libSegFault.so -> libSegFault.so
libss.so.2 -> libss.so.2.0
libattr.so.1 -> libattr.so.1.1.0
libcap.so.1 -> libcap.so.1.10
libutil.so.1 -> libutil-2.5.so
libwrap.so.0 -> libwrap.so.0.7.6
libnss_compat.so.2 -> libnss_compat-2.5.so
libproc-3.2.7.so -> libproc-3.2.7.so
libacl.so.1 -> libacl.so.1.1.0
libnsl.so.1 -> libnsl-2.5.so
libnss_dns.so.2 -> libnss_dns-2.5.so
libexpat.so.0 -> libexpat.so.0.5.0
libkeyutils.so.1 -> libkeyutils-1.2.so
libdmraid.so.1.0.0.rc13-17 -> libdmraid.so.1.0.0.rc13-17
libthread_db.so.1 -> libthread_db-1.0.so
libnss_files.so.2 -> libnss_files-2.5.so
libasound.so.2 -> libasound.so.2.0.0
libm.so.6 -> libm-2.5.so
libdb-4.3.so -> libdb-4.3.so
libselinux.so.1 -> libselinux.so.1
libnss_hesiod.so.2 -> libnss_hesiod-2.5.so
libcidn.so.1 -> libcidn-2.5.so
libnss_winbind.so.2 -> libnss_winbind.so.2
libgthread-2.0.so.0 -> libgthread-2.0.so.0.1200.3
libanl.so.1 -> libanl-2.5.so
libdevmapper.so.1.02 -> libdevmapper.so.1.02
libe2p.so.2 -> libe2p.so.2.3
libresolv.so.2 -> libresolv-2.5.so
libdl.so.2 -> libdl-2.5.so
libnss_nis.so.2 -> libnss_nis-2.5.so
libdb_cxx-4.1.so -> libdb_cxx-4.1.so


Any ideas for me would be greatly appreciated as I am stuck!

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Lynn,

    Welcome to the forum.

    Let's go through your attempts one by one:
    [root /]# slice2php /var/lib/mumble-server/Murmur.ice
    sh: slice2php: command not found
    This means you don't have /opt/Ice-3.4.2/bin in your PATH.
    [root /]# /opt/Ice-3.4.2/bin/slice2php Murmur.ice
    /opt/Ice-3.4.2/bin/slice2php: error: cannot open `/Murmur.ice' for reading
    If Murmur.ice is not present in your current directory, you need to specify the full pathname for the file.
    [root /var/lib/mumble-server]# /opt/Ice-3.4.2/bin/slice2php Murmur.ice
    /var/lib/mumble-server/Murmur.ice:9: error: Can't open include file "Ice/SliceChecksumDict.ice"
    #include <Ice/SliceChecksumDict.ice>
    1 error in preprocessor.
    So close! You can tell that slice2php is reading your file, because the file must contain an #include statement referring to SliceChecksumDict.ice. All you are missing here is the -I/opt/Ice-3.4.2/slice option.
    [root /]# slice2PHP -I/opt/Ice-3.4.2/slice /var/lib/mumble-server/Murmur.ice
    sh: slice2PHP: command not found
    Linux is case sensitive, so you have you use slice2php and not slice2PHP.

    Try this:

    [root /var/lib/mumble-server]# /opt/Ice-3.4.2/bin/slice2php -I/opt/Ice-3.4.2/slice Murmur.ice

    If everything goes well, it will silently create Murmur.php in your current directory.

    Regards,
    Mark
  • DPMDPM Member Lynn FortinOrganization: Easy Company GamingProject: Mumbles with Ice
    Worked like a charm :) Thank you very much for the assistance :D
Sign In or Register to comment.