Home Help Center

Freeze build in Redhat Linux

yomiyomi Member ✭✭
When compiled to TransactionI.cpp, build failed. Seems because berkelydb head file is not include, DbDeadlockException is not refrenced?
I try to include db_cxx.h, still failed. I will try more, but maybe someone knows why.

Comments

  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi Yomi,

    Are you using the proper version of Berkeley DB (4.1.25 or 4.2.52)? RedHat Linux 8 and 9 include older versions.

    Did you configure Berkeley DB with C++ enabled (--enable-cxx)?

    Cheers,
    Bernard
  • yomiyomi Member ✭✭
    Yes, I have new version of berkeleydb downloaded, but not with enable-cxx configure.

    Now I have reconfig berkleydb with enable-cxx configuration.
    Still not works.
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Did you edit $ICE_HOME/config/Make.rules or set the env variable $DB_HOME to point to your Berkeley DB 4.2.52 directory?

    Could you maybe post the c++ compile command that is failing?

    Cheers,
    Bernard
  • yomiyomi Member ✭✭
    Thank you, Bernard.

    I config Make.rules, set DB_HOME.
    I didn't notice this because I have make install berkeley db and the compiler didn't give the information such as db_cxx.h not found.
    Sorry for my careless.

    yomi
Sign In or Register to comment.