Home Help Center

Issue with Clock Demo on multiple hosts

nsriramnsriram Member Sriram NarasimhanOrganization: UCSCProject: MATLAB Simulation
I am playing with clock demo (I see same issue with csharp and java versions). I have a 2 machine setup one running windows xp and other running windows 7. I start the ice storm service on the windows xp machine. When I start a subscriber on the windows xp machine and a publisher on the windows 7 machine I can see the ticks in the subscriber. However if I switch them around (publisher on windows xp machine and subscriber on windows 7 machine) then I do not see ticks in the subscriber on the windows 7 machine. I have checked the firewall on both computers and made sure they accept incoming and outgoing traffic on all relevant ports.

I was hoping somebody has seen this issue before and has a simple fix.

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    There's no error on the publisher or subscriber side? To investigate this, I recommend enabling protocol tracing on the subscriber and publisher with Ice.Trace.Protcol=1 and also enable subscriber tracing on IceStorm with IceStorm.Trace.Subscriber=2.

    Cheers,
    Benoit.
  • terminateterminate Member Jone QuOrganization: iFisher CO.,LTDProject: Process Control System for Hot Furnace in Shandong
    IceStorm demo clock

    I have met with the same question. The subscriber on Win7 got nothing.
    I debug into the subscriber source code, the error occurred at

    IceStorm::TopicManagerPrx manager = IceStorm::TopicManagerPrx::checkedCast(
    communicator()->propertyToProxy("TopicManager.Proxy"));
    And get the exception 'Ice::SocketException: socket exception'


    Could you give me some advice?
  • terminateterminate Member Jone QuOrganization: iFisher CO.,LTDProject: Process Control System for Hot Furnace in Shandong
    it can work now

    For Win7 I have to open the entry connection state for the firewall in the senior firewall setting.
Sign In or Register to comment.