Home Help Center

libdb4.8++-dev is not available

snowflowersnowflower Member SY JeongOrganization: KNUProject: distributed LBS system
Hi.
I can't compile ice 3.4.1 cpp due to the DB version (4.8) for freeze as shown in following message.

...
making all in Freeze
make[2]: Entering directory `/home/ubuntu/Ice-3.4.1/cpp/src/Freeze'
c++ -c -I.. -I../../include -DFREEZE_API_EXPORTS -Wall -D_REENTRANT -fPIC -gp
In file included from ../Freeze/ConnectionI.h:15:0,
from ../Freeze/MapI.h:14,
from MapI.cpp:10:
../Freeze/TransactionI.h:15:20: fatal error: db_cxx.h: No such file or directory
compilation terminated.
...

I have tried to install the Berkeley DB 4.8 in ubuntu 10.04, but the apt-get for libdb4.8++-dev says 'package libdb4.8++ is not available'

Package libdb4.8++-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libdb4.8++-dev' has no installation candidate

I didn't search this db4.8++dev, but I got the libdb5.1++-dev.
Could I use the DB 5.1++ version? or Could I get the DB 4.8++-dev for ARM system?

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    I recommend using Ice 3.4.2 instead of 3.4.1. The simplest is to re-compile BerkeleyDB 4.8 on your platform, you'll find the Ice third party package sources on our web site here.

    Note that there are also Ubuntu Ice packages available here, we do not maintain those packages however so if you have any issues with using them you should contain the maintainer directly (see also this thread for more information on the Debian packages).

    Cheers,
    Benoit.
  • snowflowersnowflower Member SY JeongOrganization: KNUProject: distributed LBS system
    Thank you for your quick reply.

    Thank you for your quick reply.

    I will try to compile with new version. :)
Sign In or Register to comment.