Apache start: Unable to initialize module -> API problem

z3r0t3nz3r0t3n Fabian DellwingOrganization: Zero's Gaming - Community ProjectProject: Hosting a Muble-ServerMember
Hello everybody!

I got a problem while installing MAP für MurMur.

I configure the ice.ini correctly
extension=IcePHP.so
ice.slice=/home/mumble/murmur/Murmur.ice

but when I restart my apache i get this error:

PHP Warning: PHP Startup: ice: Unable to initialize module\nModule compiled with module API=20060613\nPHP compiled with module API=20090626\nThese options need to match\n in Unknown on line 0

ice version: 3.4.2
php version: 5.3.15

I talk with the programmer of MAP and he also didn't found any error in the configuration.

I hope someone has an idea.

greets Fabian

p.s. I also try to reinstall ice and so, but the error stays the same

Comments

  • benoitbenoit Rennes, FranceBenoit FoucherOrganization: ZeroC, Inc.Project: IceAdministrators, ZeroC Staff ZeroC Staff
    Hi,

    It looks like you're using a PHP version which is incompatible with the IcePHP module from Ice 3.4.2. See our supported platforms page for a list of supported platforms and PHP versions supported by Ice 3.4.2.

    You'll either need to downgrade your PHP version to a supported version or re-compile the IcePHP module using the Ice 3.4.2 distribution available on our download page.

    Cheers,
    Benoit.
  • z3r0t3nz3r0t3n Fabian DellwingOrganization: Zero's Gaming - Community ProjectProject: Hosting a Muble-ServerMember
    benoit wrote: »
    You'll either need to downgrade your PHP version to a supported version

    This will not work for me, because I need PHP 5.3.x for some of my other projects.
    benoit wrote: »
    or re-compile the IcePHP module using the Ice 3.4.2 distribution available on our download page.

    Does anyone has a good tutorial for compiling the IcePHP by myself or better has a IcePHP.so that is compiled under PHP 5.3.x?
Sign In or Register to comment.