This forum has been archived. Please start a new discussion on GitHub.

installing on fedora 8

Hello. I need to build and run an app that uses Ice on a machine running Linux Fedora 8. I hope it is still possible. Here is what I have tried, based on instructions found at ZeroC - Download

1. created /etc/yum.repos.d/zeroc-ice-el6.repo containing:
name=Ice 3.5 for RHEL $releasever - $basearch

2. tested yum using the recommended search command:
# yum list ice* db53* mcpp-devel [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: zeroc-ice. Please verify its path and try again

Ideas welcome. Thanks in advance.

Elwood Downey, Software Engineer
Large Binocular Telescope Interferometer
University of Arizona, Tucson AZ


  • xdm
    xdm La Coruña, Spain
    Hi Elwood,

    We don't officially support any Fedora version, and i don't know if Fedora 8 is binary compatible with rhel6.

    The 404 HTTP error is caused because you are using the rhel 6 yum repository, which uses some environment variables in the base URL and that variables are different in Fedora8.

    You can edit the "zeroc-ice-el6.repo" file and update the baseurl variable, it should like:

    But i cannot assure you that this will work as we don't support Fedora8, if you have problems using the binary distribution you can give a try to the source distribution and try to build Ice 3.5 from sources for your platform.

    Best Regards,
  • Hello Jose,

    That helped move things along but there are still tons of missing dependencies on older lib versions, even very basic stuff like libstdc++. Tried the source kit but it's no better. I accept f8 is very old. Thanks anyway.