Home Bug Reports

ICee 1.3 and gcc 4.7

flatmaxflatmax Member Matt FlaxOrganization: Sole TraderProject: Comms with embedded devices
Hi there,

I am trying to compile Icee 1.3 using a newer gcc 4.7.

I get the following problem :
../../include/IceE/Handle.h: In instantiation of 'IceInternal::Handle<T>::~Handle() [with T = Ice::Communicator]':
../../include/IceE/Proxy.h:73:36: required from here
../../include/IceE/Handle.h:331:13: error: 'upCast' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]

Are there any currently known work arounds ?

thanks
Matt

Comments

  • flatmaxflatmax Member Matt FlaxOrganization: Sole TraderProject: Comms with embedded devices
    I have added -fpermissive to get around this.
    flatmax wrote: »
    Hi there,

    I am trying to compile Icee 1.3 using a newer gcc 4.7.

    I get the following problem :
    ../../include/IceE/Handle.h: In instantiation of 'IceInternal::Handle<T>::~Handle() [with T = Ice::Communicator]':
    ../../include/IceE/Proxy.h:73:36: required from here
    ../../include/IceE/Handle.h:331:13: error: 'upCast' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]

    Are there any currently known work arounds ?

    thanks
    Matt
Sign In or Register to comment.