Home Help Center

Ice3.4.2 c++ demo--IceStorm replicated "connection refused"

liuYFliuYF Member Liu YunFeiOrganization: casriProject: using video technology to detect airport fods
Hello,I'm a new learner. now I have some problem in learn Icestorm HA.

The demo location is:
D:\zeroc\demo\IceStorm\replicated

The problem is:

IceStorm-replicated c++ demo can run normally when subscriber and publisher on the same computer(don't change anything for config files).

but when publisher on the A computer(IP: 192.168.0.113), subscriber on the B computer(IP: 192.168.0.188). It will appear Ice::connectionRefusedException error "remote computer refused connection".

In the configure file I only change some lines. such as follows:

#####config.grid#####
Ice.Default.Locator=DemoIceGrid/Locator:default -h 192.168.0.113 -p 4061

#####config.pub#####
Ice.Default.Locator=DemoIceGrid/Locator:default -h 192.168.0.113 -p 4061

TopicManager.Proxy=DemoIceStorm/TopicManager:default -h 192.168.0.113 -p 10001

#####config.sub#####
Ice.Default.Locator=DemoIceGrid/Locator:default -h 192.168.0.113 -p 4061

TopicManager.Proxy=DemoIceStorm/TopicManager:default -h 192.168.0.113 -p 10001

Clock.Subscriber.Endpoints=tcp -h 192.168.0.188:udp -h 192.168.0.188

when I use IP Address to "127.0.0.1" instead "192.168,0.113" and "192.168.0.188".Run subscriber and publisher on the same computer, It still appear the same error!

For this error, I thought maybe there's something wrong in the config file, but I don't konw how to config it.

Addition: application file need to change? If answer is need? how do I change it?

can you help me? Thanks very much!

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    Did you also update the endpoints property in the IceGrid registry and node configuration file? You need to replace the "-h localhost" options in config.grid configuration file to specify the appropriate IP addresses.

    Also, I recommend to upgrade to Ice 3.5.1, we only provide free support on the forums for the latest Ice versions.

    Cheers,
    Benoit.
  • liuYFliuYF Member Liu YunFeiOrganization: casriProject: using video technology to detect airport fods
    benoit wrote: »
    Hi,

    Did you also update the endpoints property in the IceGrid registry and node configuration file? You need to replace the "-h localhost" options in config.grid configuration file to specify the appropriate IP addresses.

    Also, I recommend to upgrade to Ice 3.5.1, we only provide free support on the forums for the latest Ice versions.

    Cheers,
    Benoit.

    As you say,In config.grid file,I changed like this

    Ice.Default.Locator=DemoIceGrid/Locator:default -h 192.168.0.113 -p 4061

    IceGrid.Registry.Client.Endpoints=default -h 192.168.0.113 -p 4061
    IceGrid.Registry.Server.Endpoints=default -h 192.168.0.113
    IceGrid.Registry.Internal.Endpoints=default -h 192.168.0.113

    IceGrid.Node.Endpoints=default -h 192.168.0.113

    But It does no seem to help.

    In application.xml file, following are or need to change?

    <parameter name="topic-manager-endpoints" default="default"/>
    <parameter name="publish-endpoints" default="default"/>
    <parameter name="node-endpoints" default="default"/>


    <parameter name="topic-manager-endpoints" default="default -h 192.168.0.113"/>
    <parameter name="publish-endpoints" default="default -h 192.168.0.113"/>
    <parameter name="node-endpoints" default="default -h 192.168.0.113"/>

    In addition, our system include client and server, It's based on ice-3.4.1, how to upgrade it to ice-3.5.1?
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    See the Ice release notes for information on how to upgrade to Ice 3.5.1.

    Keeping "default" for the IceStorm endpoints should be fine. When no "-h" option is specified, Ice listens on all the available network interfaces. However, if you have network interfaces which aren't accessible to the client on the machine, you could also use "default -h 192.168.0.113" to force Ice to listen only on this specific interface.

    I recommend to enable network tracing on your publisher and subscriber with --Ice.Trace.Network=2, it should print some traces showing the IP address and port it tries to connect to and for which it's failing.

    Cheers,
    Benoit.
Sign In or Register to comment.