IceJ-1.5.0 allTests.py assertion error?

(This is on a RedHat 9.0 system with gcc3.2.2 and Sun JDK1.4.2_03 and DB4.1.25.
Ice/IceJ 1.2.0 and 1.3.0 have been built successfully on this system before.)

I'm trying to install the new Ice(C++) and IceJ 1.5.0 versions. The C++ version built
and passed all of its tests just fine, but I'm getting an assertion error from IceJ when
running "python allTests.py":

*** running tests in ./test/Freeze/dbmap
starting client... ok
testing populate... Exception in thread "main" java.lang.AssertionError
at Freeze.Map.containsKey(Map.java:177)
at Client.run(Client.java:224)
at Client.main(Client.java:496)
Traceback (most recent call last):
File "./test/Freeze/dbmap/run.py", line 36, in ?
TestUtil.printOutputFromPipe(clientPipe)
File "./config/TestUtil.py", line 123, in printOutputFromPipe
c = pipe.read(1)
KeyboardInterrupt
test in ./test/Freeze/dbmap failed with exit status 256

CLASSPATH, LD_LIBRARY_PATH, and ICE_HOME are:

weaver% echo $CLASSPATH
/opt/db/lib/db.jar:lib/Ice.jar:/opt/java/jmf/JMF-2.1.1e/lib/jmf.jar:.::/opt/java4/jre/lib/rt.jar
weaver% echo $LD_LIBRARY_PATH
/opt/db/lib
weaver% echo $ICE_HOME
/opt/Ice-1.5.0

all of which are correct for this system.

Any ideas on what I've got wrong? Thanks!

Comments

  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Hi Steve,

    This error occurs because the IceJ distribution is compiled against the class files from BerkeleyDB 4.2.52. I get the same error if I run the test with 4.1.25 in my CLASSPATH.

    You can either rebuild IceJ from sources against 4.1.25, or upgrade to 4.2.52.

    Take care,
    - Mark
  • SteveWamplerSteveWampler Member ✭✭
    Thanks!!! (I'll upgrade DB4)

    Incidently, the INSTALL file for IceJ says it's compiled against 4.1.25, so that doc should
    probably be updated.
  • SteveWamplerSteveWampler Member ✭✭
    Hi Michi,

    Python reports itself as:

    Python 2.2.3 (#1, Jul 8 2003, 16:35:47)

    When I go into the test/Freeze/dbmap directory and run "python run.py" I get
    the same error:

    weaver% python run.py
    starting client... ok
    testing populate... Exception in thread "main" java.lang.AssertionError
    at Freeze.Map.containsKey(Map.java:177)
    at Client.run(Client.java:224)
    at Client.main(Client.java:496)
    Traceback (most recent call last):
    File "run.py", line 36, in ?
    TestUtil.printOutputFromPipe(clientPipe)
    File "../../../config/TestUtil.py", line 123, in printOutputFromPipe
    c = pipe.read(1)
    KeyboardInterrupt

    I'll report back if I have problems after upgrading db4.
  • mesmes CaliforniaAdministrators, ZeroC Staff Mark SpruiellOrganization: ZeroC, Inc.Project: Ice Developer ZeroC Staff
    Originally posted by SteveWampler
    Incidently, the INSTALL file for IceJ says it's compiled against 4.1.25, so that doc should
    probably be updated.
    Will do, thanks.

    - Mark
  • michimichi Member Michi HenningOrganization: Triodia TechnologiesProject: I have a passing interest in Ice :-) ✭✭✭
    Originally posted by SteveWampler
    Hi Michi,

    Python reports itself as:

    Python 2.2.3 (#1, Jul 8 2003, 16:35:47)


    Hi Steve,

    Mark and I replied in parallel. Turns out that Mark spotted the problem and I was barking up the wrong tree, so I deleted my reply again. Of course, you spotted my reply before I deleted it and replied to that :)

    So, discard what I said. The problem isn't caused by Python and there is nothing wrong with your Python version.

    Sorry for the confusion.

    Cheers,

    Michi.
  • SteveWamplerSteveWampler Member ✭✭
    Just verifying that upgrading to db4.2.52 solved this problem.

    Thanks for the quick help!
Sign In or Register to comment.