Home Help Center

IcePack question

wodiwodi Member
Hi,

if starting the following IcePack Registry-/Node-setup in a batch file:

start icepackregistry --Ice.Config=registry.config
pause ...
start icepacknode --Ice.Config=node-1.config
rem pause ...
start icepacknode --Ice.Config=node-2.config
rem pause ...
start icepacknode --Ice.Config=node-3.config
pause ...
icepackadmin --Ice.Config=admin.config

with registry.config as:

#
# The IcePack locator proxy.
#
Ice.Default.Locator=IcePack/Locator:default -p 12000

#
# IcePack registry configuration.
#
IcePack.Registry.Client.Endpoints=default -p 12000
IcePack.Registry.Server.Endpoints=default
IcePack.Registry.Internal.Endpoints=default
IcePack.Registry.Admin.Endpoints=default
IcePack.Registry.Data=db/registry
IcePack.Registry.DynamicRegistration=1

#
#
#
Ice.ThreadPool.Server.Size = 50
Ice.ThreadPool.Client.Size = 20

#
# Trace properties.
#
IcePack.Registry.Trace.ServerRegistry=1
IcePack.Registry.Trace.AdapterRegistry=1
IcePack.Registry.Trace.NodeRegistry=1
IcePack.Registry.Trace.ObjectRegistry=1

and each node-x.config as:

#
# The IcePack locator proxy.
#
Ice.Default.Locator=IcePack/Locator:default -p 12000

#
# IcePack node configuration.
#
IcePack.Node.Name=node-x
IcePack.Node.Endpoints=default
IcePack.Node.Data=db/node-x
IcePack.Node.CollocateRegistry=0
IcePack.Node.RedirectErrToOut=1
IcePack.Node.WaitTime=60
IcePack.Node.PrintServersReady=node-x:all servers

#
# Trace properties.
#
IcePack.Node.Trace.Activator=3
IcePack.Node.Trace.Adapter=2
IcePack.Node.Trace.Server=3

the registry and all nodes will hang. if they are started as in the batch file above.

However, if there is introduced a delay between the starting of the IcePack Nodes by waiting until each of the nodes has output its ServersReady message, the configuration is working as expected.

The system is Ice 1.5.1 C++ on Windows XP. All Icepack items are started on the same host.

Is this behaviour as expected?

Cheers,

Wodi

Comments

  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    No, this is not expected, the registry or nodes shouldn't hang in any circumstances! I'll try to reproduce this problem and let you know what I find out!

    Benoit.
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Wodi,

    I've been able to reproduce your problem and here's a fix. You need to replace the Ice-1.5.1/src/IcePack/NodeRegistryI.cpp file from your source distribution with the attached file and recompile the IcePack node.

    Thanks for reporting this issue, this fix will be included with the next release!

    Benoit.
  • wodiwodi Member
    Hi Benoit,

    thanks for the quick fix.

    Cheers,

    Wodi
Sign In or Register to comment.