Home Help Center

Does Ice 3.2 really require DB4 4.5?

mefostermefoster Member Mary Ellen FosterOrganization: Heriot-Watt University, EdinburghProject: ECHOES learning environment ✭✭✭
I'm trying to build Ice 3.2 on Fedora (FC6), and the srpm wants db4 version 4.5.20. Is that a hard dependency? The version shipped with FC6 is 4.3.29; 4.5 is coming in Fedora 7 when that comes out, but I'd like to build this now.

Thanks for any advice,

MEF

Comments

  • Andreas_SchererAndreas_Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby
    OpenSUSE only has "db-4.3.27-7", but by commenting the three related lines (among others) in "ice-3.2.0.spec" all compiles and links fine. And the "Freeze/phonebook" demo also works as expected.

    Take care,
    Andreas
  • bernardbernard Administrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Ice 3.2 is only supported with DB 4.5.20. We test with this release of Berkeley DB and recommend to use it.

    Since the Berkeley DB API is fairly stable, I expect Ice 3.2 to build properly with DB >=4.2 (for C++) and DB >=4.3 or later (for Java).
    We found some problem with Freeze/DB 4.3 when running on a 64-bit JVM, so if you're running in this environment, it would make sense to upgrade your Berkeley DB version.

    We also provide the source RPM for db45, see http://www.zeroc.com/download.html#src_third_party

    The files in these db45 RPMs (for C/C++ and Java) can coexist with other Berkeley DB installations. If you're building another Ice RPM distribution, why not build these RPMs as well?

    Cheers,
    Bernard
  • mefostermefoster Member Mary Ellen FosterOrganization: Heriot-Watt University, EdinburghProject: ECHOES learning environment ✭✭✭
    How about Mono 1.2.2?

    Similar question, and I suspect I'll probably get the same answer: how strict is the dependency on mono-core >= 1.2.2? Again, I think that's coming in Fedora 7, but FC6 has 1.1.17. I don't actually use C# so I could just disable that part of the RPM, but I'd like to know what the actual requirement is.

    MEF
  • Andreas_SchererAndreas_Scherer Member Andreas SchererOrganization: Private Linux SiteProject: Evaluating Ice-C++, Ice-Python, Ice-Ruby
    mefoster wrote: »
    I could just disable that part of the RPM
    That's exactly what I do here ;), so I can not give any further recommendations on Mono. (OpenSUSE 10.0 seems to provide Mono version 1.1.8, but I don't have this installed.)

    Take care,
    Andreas

    PS: Mono version 1.2.3.1 is provided as a bundle of rpms for OpenSUSE 10.0 (among lots of other systems) but obviously not specifically for FC6, so I could easily upgrade in case of need (rpm -i --test says OK). See http://www.mono-project.com/Downloads for details.
  • benoitbenoit Administrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    Yes, it's the same for Mono. We officially support Ice for C# with mono >= 1.2.2.1. That's what we used to test Ice for C# for the 3.2 release. Ice for C# might still work with 1.1.17 though. Just try it out and see if the test suite runs successfully :)

    Cheers,
    Benoit.
Sign In or Register to comment.