Home Help Center

Ice Debian Packages

jessejesse Member Jesse AndersonOrganization: Bright SystemsProject: Data Moving ✭✭
I am trying to install the Ice 3.3 release Debian packages. I added the following lines to my /etc/apt/sources.list.
deb http://arco.inf-cr.uclm.es/~francisco.moya/debian/ ./
deb-src http://arco.inf-cr.uclm.es/~francisco.moya/debian/ ./

When I try to install it, I get the following error:
[email protected]:~$ sudo apt-get install zeroc-ice33
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  zeroc-ice33: Depends: ice33-services (>= 3.3.0-1) but it is not installable
               Depends: ice33-translators (>= 3.3.0-1) but it is not installable
               Depends: libzeroc-ice33-dev (>= 3.3.0-1) but it is not installable
               Depends: libzeroc-ice-3.3-cil (>= 3.3.0-1) but it is not going to be installed
               Depends: python-zeroc-ice (>= 3.3.0-1) but 3.2.1-1 is to be installed
               Depends: php-zeroc-ice (>= 3.3.0-1) but 3.2.1-1 is to be installed
E: Broken packages

Am I missing another repository?

Comments

  • jessejesse Member Jesse AndersonOrganization: Bright SystemsProject: Data Moving ✭✭
    I forgot to add I am using Ubuntu 7.10 and "ice33-services", etc are found in the apt repository.
  • jessejesse Member Jesse AndersonOrganization: Bright SystemsProject: Data Moving ✭✭
    jesse wrote: »
    I forgot to add I am using Ubuntu 7.10 and "ice33-services", etc are found in the apt repository.

    It should say "are NOT found in the apt repository".
  • bernardbernard Jupiter, FLAdministrators, ZeroC Staff Bernard NormierOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi Jesse,

    Ice 3.3.0 was released yesterday (less than 24h ago); I'd be surprised if binary packages for Debian, Gentoo, Fedora, Slackware etc. were already available! On Linux, ZeroC provides binaries only for Red Hat Enterprise Linux 4.6, 5.1, and SuSE Linux Enterprise Server 10 SP1.

    If you want to try Ice 3.3.0 on Debian right away, I recommend to build Ice from source; this should be straightforward on any recent Linux distribution.

    Cheers,
    Bernard
  • jessejesse Member Jesse AndersonOrganization: Bright SystemsProject: Data Moving ✭✭
    I had the same issue with installing the beta debian packages. Also, the package names have changed since the beta, so they appear to be the release version.
  • ctennisctennis Member Caleb TennisOrganization: AEIProject: Project GINA ✭✭✭
    Packages for Gentoo are available! :)
  • fmoyafmoya Member Francisco MoyaOrganization: UCLMProject: Debian packages ✭✭
    jesse wrote: »
    When I try to install it, I get the following error:
    [email protected]:~$ sudo apt-get install zeroc-ice33
    ...
    The following packages have unmet dependencies:
      zeroc-ice33: Depends: ice33-services (>= 3.3.0-1) but it is not installable
                   Depends: ice33-translators (>= 3.3.0-1) but it is not installable
                   Depends: libzeroc-ice33-dev (>= 3.3.0-1) but it is not installable
                   Depends: libzeroc-ice-3.3-cil (>= 3.3.0-1) but it is not going to be installed
                   Depends: python-zeroc-ice (>= 3.3.0-1) but 3.2.1-1 is to be installed
                   Depends: php-zeroc-ice (>= 3.3.0-1) but 3.2.1-1 is to be installed
    E: Broken packages
    

    I guess you are using an architecture different from i386. You have several options:
    • Add another repo for your architecture
    • Compile the package yourself
    • Wait for the official debian packages

    If you use PPC or an amd64 then you may just add the following repos (in addition to the i386 repo):
    deb http://arco.inf-cr.uclm.es/~francisco.moya/debian-ppc ./
    deb http://arco.inf-cr.uclm.es/~francisco.moya/debian-amd64 ./
    

    But I rely on some other people to generate those packages. Therefore they may be a bit outdated.

    Compiling the Debian packages yourself is not that difficult either:
    apt-get source zeroc-ice
    cd zeroc-ice-*
    

    Now you should ensure that you install the packages listed in file debian/control labeled with Build-Depends or Build-Depends-Indep. You may use /usr/lib/pbuilder/pbuilder-satisfydepends to automate that.
    fakeroot ./debian/rules binary
    dpkg -i ../*.deb
    

    The official Debian packages will be available in a few days.

    Regards,
    F. Moya
  • michimichi Member Michi HenningOrganization: Triodia TechnologiesProject: I have a passing interest in Ice :-) ✭✭✭
    ctennis wrote: »
    Packages for Gentoo are available! :)

    Man, you are setting high expectations... Next time, people will expect you to have the packages available in less than 10 milliseconds after a new Ice release ;)

    Cheers,

    Michi.
  • jessejesse Member Jesse AndersonOrganization: Bright SystemsProject: Data Moving ✭✭
    Yes, the issue was 64-bit. Also, the 64-bit repository is still the beta code. If only they could be like the Gentoo maintainers! :D
  • linuxpowerlinuxpower Member Markus BauerOrganization: linux-power.deProject: Mumble
    Hi,

    im searching for a repository server for debian 4 and all Ice 3.3 packages. All sources that i use didn´t match. Always the same massage will displayed:

    The following packages have unmet dependencies:
    zeroc-ice33: Depends: ice33-services (>= 3.3.0-10) but it is not installable
    Depends: ice33-translators (>= 3.3.0-10) but it is not installable
    Depends: ice33-slice (>= 3.3.0-10) but it is not installable
    Depends: libzeroc-ice33-dev (>= 3.3.0-10) but it is not installable
    Depends: libzeroc-ice-3.3-cil (>= 3.3.0-10) but it is not installable
    Depends: python-zeroc-ice (>= 3.3.0-10) but 3.1.1-1 is to be installed
    Depends: php-zeroc-ice (>= 3.3.0-10) but 3.1.1-1 is to be installed
    Depends: libzeroc-ice-java (>= 3.3.0-10) but 3.1.1-2 is to be installed
    Depends: icegrid-gui (>= 3.3.0-10) but 3.1.1-2 is to be installed


    Can anyone tell me a source server there i can install all packages? The server there posted in this thread doesn´t work. :(

    Thx
    Markus
  • fmoyafmoya Member Francisco MoyaOrganization: UCLMProject: Debian packages ✭✭
    You are using the stable distribution, way too old.

    ZeroC Ice 3.3 is already available on unstable for all supported platforms.

    For the convenience of some users I made a backport of Ice 3.3 to testing (lenny). Lenny is going to be released as stable in the coming weeks but it will include Ice 3.2. Unfortunately I only provide i386 packages. This is my lenny repo:
    deb http://arco.esi.uclm.es/~francisco.moya/debian-lenny/ ./
    deb-src http://arco.esi.uclm.es/~francisco.moya/debian/ ./
    

    If you are not willing to switch to unstable and you use an architecture other than i386 then you must compile the packages yourself, as explained in this thread.

    Of course you may always use apt pinning but I wouldn't recommend it. There are too many dependencies.

    Regards,
    F. Moya
  • pjtaitpjtait Member Philip TaitOrganization: Subaru TelescopeProject: Fibre-Fed Multi-ObjectSpectrograph;HyperSuprimeCam ✭✭
    Missing rc startup scripts?

    I just installed all of the zeroc-ice packages on Debian Lenny - very helpful, thanks! However, I was surprised to see there were no startup scripts in the packages.

    Fortunately, I also have a CentOS 5 box with the official RPMs installed, so I can copy from there, but I wondered if I had missed a needed package, or whether this is just something that didn't get included?
  • DeepDiverDeepDiver Member Thomas MuellerOrganization: Freelance Software DeveloperProject: Project depend on Customers ✭✭✭
    pjtait wrote: »
    I just installed all of the zeroc-ice packages on Debian Lenny - very helpful, thanks! However, I was surprised to see there were no startup scripts in the packages.

    Fortunately, I also have a CentOS 5 box with the official RPMs installed, so I can copy from there, but I wondered if I had missed a needed package, or whether this is just something that didn't get included?

    I'd suggest to file a bug report within Debian and/or contact the maintainer:
    Debian Package Tracking System - zeroc-ice

    But the package is outdated - still on 3.3.1 - looks like dead to me.
    The maintainer didn't react to emails and bug-reports for a quite long time.

    Someone shall take care about this package .... I wish I had more time - let's see ....

    Regards,

    Thomas
  • cleto.martincleto.martin Member Cleto MartinOrganization: University of Castilla-La ManchaProject: Distributed Systems
    Ice 3.4.1 is debianized

    Hi!

    It is true Ice Debian packages are too old. Franciso Moya is currently the maintainer and he is so busy. For that reason, I have built Ice 3.4.1 packages from Francisco's version. The packages are still in development. I hope next week new packages will be availables at Debian sid.

    Meanwhile, you may install the new version from following unofficial repository (add it to your /etc/apt/sources.list):

    deb http://babel.esi.uclm.es/arco experimental main

    Hope this help.

    Cheers,
    Cleto.
  • cleto.martincleto.martin Member Cleto MartinOrganization: University of Castilla-La ManchaProject: Distributed Systems
    Hi!
    pjtait wrote: »
    I just installed all of the zeroc-ice packages on Debian Lenny - very helpful, thanks! However, I was surprised to see there were no startup scripts in the packages.

    I don't understand very well what you refer. Do you mean startup scripts for running an icegridnode at boot time? For this case, long time ago, I built a Debian package called 'icegridnode-setup' which included startup scripts for lauching an icegridnode service at boot time. I've never publish this package, but if you think it would be useful I may publish it at Debian.

    About Ice 3.4.1 packages, they are already uploaded and, at this moment, are being checked because new packages (like libicedb) have been created. I hope packages will be available soon.

    Cheers,
    Cleto.
  • pjtaitpjtait Member Philip TaitOrganization: Subaru TelescopeProject: Fibre-Fed Multi-ObjectSpectrograph;HyperSuprimeCam ✭✭
    Init scripts

    Thanks Cleto, yes, I did mean the init.d scripts to start icegridnode. That would be nice to have included.
Sign In or Register to comment.