Home Help Center

no suitable endpoint available for proxy `hello -t'

zeronumberzeronumber Member jack zhangOrganization: DawningProject: Beijing police station
Problems about “no suitable endpoint available for proxy `hello -t'”

I have 3 computers,one is used as the client(10.0.38.126),one is used as the registry(10.0.38.127),and the other is used as the server(10.0.38.128). And I tested in Ice-3.3.1/cpp/demo/IceGrid/simple.

In the registry, I modified the file of config.grid,and added the IP of registry as follows:
#
# The IceGrid locator proxy.
#
Ice.Default.Locator=DemoIceGrid/Locator:default -p 4061 -h 10.0.38.127

#
# IceGrid registry configuration.
#
IceGrid.Registry.Client.Endpoints=default -p 4061  -h 10.0.38.127
IceGrid.Registry.Server.Endpoints=default -h 10.0.38.127
IceGrid.Registry.Internal.Endpoints=default -h 10.0.38.127

In the server, I modified the file of config.grid ,and added the IP of registry as follows:
#
# The IceGrid locator proxy.
#
Ice.Default.Locator=DemoIceGrid/Locator:default -p 4061 -h 10.0.38.127

and also,In the server, I modified the file of config.grid ,and enabled the node and trace propertiees as follows:
# IceGrid node configuration.
#
IceGrid.Node.Name=localhost
IceGrid.Node.Endpoints=default
IceGrid.Node.Data=db/node
IceGrid.Node.CollocateRegistry=1
IceGrid.Node.Output=db
IceGrid.Node.RedirectErrToOut=1

#
# Trace properties.
#
IceGrid.Node.Trace.Activator=1
IceGrid.Node.Trace.Adapter=2
IceGrid.Node.Trace.Server=3

Then, I run the demo:
1. in the registry, I run:
icegridregistry --Ice.Config=config.grid
2. in the server, I run:
icegridnode --Ice.Config=config.grid
a few seconds later, there are some warnings appeared in the screen of the server:
linux2:~/Ice-3.3.1/cpp/demo/IceGrid/simple # icegridnode --Ice.Config=config.grid
01/28/10 05:57:58.191 icegridnode: warning: couldn't reach the IceGrid registry (this is expected if it's down, otherwise please check the value of the Ice.Default.Locator property):
ConnectionI.cpp:1308: Ice::ConnectTimeoutException:
timeout while establishing a connection
3. in the registry, I run:
icegridadmin --Ice.Config=config.grid
Ice 3.3.1  Copyright 2003-2009 ZeroC, Inc.
>>> application add "application.xml"
>>> node list
localhost
>>> node ping 'localhost'
node is up
and then, there are some information appeared in the screen of the server :
icegridnode --Ice.Config=config.grid
01/28/10 05:57:58.191 icegridnode: warning: couldn't reach the IceGrid registry (this is expected if it's down, otherwise please check the value of the Ice.Default.Locator property):
ConnectionI.cpp:1308: Ice::ConnectTimeoutException:
timeout while establishing a connection
[ 01/28/10 05:58:45.245 icegridnode: Server: changed server `SimpleServer' state to `Loading' ]
[ 01/28/10 05:58:45.247 icegridnode: Server: changed server `SimpleServer' state to `Inactive' ]
4. in the client, I run:
./clent
errors appeared:
./client: Reference.cpp:1546: Ice::NoEndpointException:
no suitable endpoint available for proxy `hello -t'

What can I do to solve the problems?:confused:

Comments

  • zeronumberzeronumber Member jack zhangOrganization: DawningProject: Beijing police station
    update~
    when i didn't modified the config.client in the client, the errors appeared as follows after the command "./client" :
    linux:~/Ice-3.3.1/cpp/demo/IceGrid/simple # ./client 
    ./client: Network.cpp:1221: Ice::ConnectionRefusedException:
    connection refused: Connection refused
    

    when i modified the config.client, adding the ip of the registry in the client like this:
    #
    # The IceGrid locator proxy.
    #
    Ice.Default.Locator=DemoIceGrid/Locator:default -p 4061 -h 10.0.38.127
    #Ice.Default.Locator=DemoIceGrid/Locator:default -p 4061
    
    the errors appeared as follows after the command "./client" :
    linux:~/Ice-3.3.1/cpp/demo/IceGrid/simple # ./client 
    ./client: Reference.cpp:1546: Ice::NoEndpointException:
    no suitable endpoint available for proxy `hello -t'
    

    How to correctly run client?
  • benoitbenoit Rennes, FranceAdministrators, ZeroC Staff Benoit FoucherOrganization: ZeroC, Inc.Project: Ice ZeroC Staff
    Hi,

    Which OS do you use?

    The client and icegridnode appear to have issues to connect to the IceGrid registry client endpoint. You can try enabling network tracing with --Ice.Trace.Network=2 to make sure they connect to the expected endpoints. You can also try to connect to the registry endpoints from the machines running the icegridnode or client using telnet to see if it works, for example:
      $ telnet 10.0.38.127 4061
    

    If you're using Windows, you should check if the Windows firewall is enabled and disable it to see it helps.

    Cheers,
    Benoit.
  • zeronumberzeronumber Member jack zhangOrganization: DawningProject: Beijing police station
    benoit wrote: »
    Hi,

    Which OS do you use?

    The client and icegridnode appear to have issues to connect to the IceGrid registry client endpoint. You can try enabling network tracing with --Ice.Trace.Network=2 to make sure they connect to the expected endpoints. You can also try to connect to the registry endpoints from the machines running the icegridnode or client using telnet to see if it works, for example:
      $ telnet 10.0.38.127 4061
    

    If you're using Windows, you should check if the Windows firewall is enabled and disable it to see it helps.

    Cheers,
    Benoit.

    ICE version:3.3.1
    OS:turbo8(i need to test on this OS, although it is not the suitable platform)
    i have tried the telnet command that you mentioned,and it works well.
    But when i run "./client",the errors appears again.
    ./client: Reference.cpp:1546: Ice::NoEndpointException:
    no suitable endpoint available for proxy `hello -t'
    
Sign In or Register to comment.