This forum has been archived. Please start a new discussion on GitHub.

how to get ice working with xcode 3.2.3 ?

the plugin doesnt work anymore i read. and on my system, the examples dont compile, so it shines to be so.
even if it recognices the .ice as a sourcecode.slice, it tells me that it doesnt know, what to do with the file.
when "precompiling" it myself with slice2obj i get those .h and .m, but there is still an object missing.

one object, if i import the framework-files manually - BUT: them are only for x86, for arm there is no way known to me until now...

so, has anyone an idea to get ice working ?

i installed the actual dmg, the single-plugin-dmg and even tried the console-installation, nothing helped. xcode is on 3.2.3 with iphone sdks from 3.0 to 4.0beta3


  • any idea? I'm interrasted with this topic
  • even a manual way without plugin would be ok, but i need to get thius to run anyhow
  • warning: no rule to process file '$(PROJECT_DIR)/Classes/' of type sourcecode.slice for architecture i386
    one example-error that comes in your demos - and i think, one of the main-problems.
  • most of my problems can be solved when running xcode in 32bit-mode (rightclick on executable -> info -> 32bit)

    but, can it be, that the demochat isnt running atm ?
  • bernard
    bernard Jupiter, FL
    The chat demo server is working. Why do you think it's down?

    Best regards,
  • youre right. at work i just have edge on my place. with edge the demo doesn't work. either did the demo not work on my place - next problem: the it shines to block the port.
    but the combination of this 2 things looked to me as if it would be offline or so.